"automatically log me in each time I visit" doesn't

Let us know if there are categories or topics to add, or what we need to do to improve these forums!
WestfW
Posts: 148
Joined: Wed May 25, 2011 12:17 am

"automatically log me in each time I visit" doesn't

Post by WestfW » Fri May 27, 2011 6:10 pm

When I log into the forum there's a checkbox that says "automatically log me in each time I visit", but it doesn't seem to have any effect. Combined with a rather short inactivity timeout that automatically logs me out, and the failure of the login page to be recognized by firefox's password-remembering tools, this makes the chipkit forum annoying to use.

(what's WITH forum software, anyway. Security is a good thing, I suppose, but I keep running into the most draconian enforcement on the sites where security seems to me to be least important ("yeah, we need an 8 character password with mixed case, numbers, and punctuation, AND a 15 minute timeout, in order for you to make pithy comments on our silly web comic..."))

(I'm using firefox 3.latest on MacOS 10.5.latest. Arduino.cc and adafruit keep me logged in (or automatically re-log me in) for days or weeks on end...)

cobbj
Site Admin
Posts: 63
Joined: Thu May 19, 2011 6:14 am

Re: "automatically log me in each time I visit" doesn't

Post by cobbj » Fri May 27, 2011 11:44 pm

I've changed a few options that should solve the timeout problem - the auto login issue will take me some time to investigate. Some of it could be an issue with mirroring - because of the way things were registered, and our end goal of using the .cc domain, we have to use a mirror instead of a redirect. If you could try using chipkit.org and let me know if autologin is still broken that would be helpful. I'll fix it - thanks for letting me know!

And sorry for the initial security - first time running a (hopefully very!!) large scale forum that people may come to depend on. Erring on the side of caution for now!

--Jeremy

WestfW
Posts: 148
Joined: Wed May 25, 2011 12:17 am

Re: "automatically log me in each time I visit" doesn't

Post by WestfW » Mon May 30, 2011 8:41 pm

I'm not noticing any difference (I guess the timeout could be longer than it was, but it still isn't more than 8 hours or so; I was on last night at 0330, and now at 1230 I had to log in again.)

jasonk
Posts: 100
Joined: Mon May 23, 2011 6:38 am
Location: Chandler, Arizona
Contact:

Re: "automatically log me in each time I visit" doesn't

Post by jasonk » Mon Jun 06, 2011 2:24 am

It seems to work for me if I use http://chipkit.org/forum, but not http://chipkit.cc/forum. I believe that it is related to my brower's cookie settings.
Jason Kajita
Microchip Technology
Follow me on Twitter

cobbj
Site Admin
Posts: 63
Joined: Thu May 19, 2011 6:14 am

Re: "automatically log me in each time I visit" doesn't

Post by cobbj » Mon Jun 06, 2011 4:41 pm

Sorry haven't had time to test yet :( Jason, if you find any problems please let me know... I still think it may be a mirroring and or browser issue...

WestfW
Posts: 148
Joined: Wed May 25, 2011 12:17 am

Re: "automatically log me in each time I visit" doesn't

Post by WestfW » Mon Jun 06, 2011 11:50 pm

seems to work for me if I use http://chipkit.org/forum
Confirmed! Yea!

cobbj
Site Admin
Posts: 63
Joined: Thu May 19, 2011 6:14 am

Re: "automatically log me in each time I visit" doesn't

Post by cobbj » Tue Jun 07, 2011 5:42 pm

I really think it is a mirroring issue. Won't be able to fix that for another month until I can transfer registrations... :(

leifaldrin
Posts: 5
Joined: Fri Jun 17, 2011 1:49 pm

Re: "automatically log me in each time I visit" doesn't

Post by leifaldrin » Sat Jun 18, 2011 6:10 am

I agree that the browser might be the problem.Try reporting to the browser provider
or try it to another browser.I am not yet experiencing that problem but willing to give you another info when I learned it.

Bypeduredads
Posts: 6
Joined: Mon Dec 05, 2011 7:53 am
Location: Austria
Contact:

"automatically log me in each time I visit" doesnt

Post by Bypeduredads » Tue Dec 06, 2011 6:00 pm

I didnt know there was a time limit. Are you sure the problem isnt on your end? Ive been signed into the forum for weeks now without ever being logged out by the system.

You might want to check your "cookies" setting. It could be that your cookies are cleared every few minutes and that would result in a log out.

Darth Maker
Posts: 40
Joined: Wed Jun 08, 2011 8:10 am

Re: "automatically log me in each time I visit" doesn't

Post by Darth Maker » Wed Dec 07, 2011 5:09 am

Both chipkit.cc/forum and chipkit.org/forum work fine for me, running Firefox 9.0 (beta stream). Auto-login works fine, and Firefox remembers my username and password if I logout (even after I restart the browser).

Post Reply