Compiler Output Stuck in a Loop

Post Reply
FredCailloux
Posts: 69
Joined: Sat Mar 28, 2015 4:45 am
Location: Quebec - Canada

Compiler Output Stuck in a Loop

Post by FredCailloux » Wed Feb 17, 2016 1:08 am

I've been using UECIDE for some time now and only twice I got this annoying behavior. On this particular example I am trying to compile a code from GitHub Superdroid called Encoder-Buffer-Breakout-master. When I try to compile the code UECIDE loop into an endless verbose output and get stuck in that loop indefinitely until I must close the whole window and restart UECIDE ( obviously empty then ). Grabbing the output text was somewhat of a challenge. I was able to put it in a text file ProcessorError.txt and the guilty code file DualEncoderBreakout.txt

Could that be a UECIDE bug ? How can we avoid the behavior ?

Thanks for your help
Attachments
ProcessorError.txt
(6.55 KiB) Downloaded 23 times
DualEncoderBreakout.txt
(6.04 KiB) Downloaded 26 times

User avatar
majenko
Site Admin
Posts: 2165
Joined: Wed Nov 09, 2011 7:51 pm
Location: UK
Contact:

Re: Compiler Output Stuck in a Loop

Post by majenko » Wed Feb 17, 2016 2:48 am

Nice. It looks like you have an Arduino version of the SPI library hanging around that's being used in preference to the chipKIT one. That's all AVR code that's spewing out there.

The library looks like it's at:

Code: Select all

D:\Bibliotheque\_Electronique\MicroControlerRoboticSOC\_Digilent_USA\IDE_UEC\libraries\SPI
Delete it and all should be well again. Why do you even have a copy of an SPI library in there? SPI is always included with the cores, and there is never a need to download or install one of your own.
Why not visit my shop? http://majenko.co.uk/catalog
Universal IDE: http://uecide.org
"I was trying to find out if it was possible to only eat one Jaffa Cake. I had to abandon the experiment because I ran out of Jaffa Cakes".

FredCailloux
Posts: 69
Joined: Sat Mar 28, 2015 4:45 am
Location: Quebec - Canada

Re: Compiler Output Stuck in a Loop

Post by FredCailloux » Wed Feb 17, 2016 4:34 pm

This libraries folder was copied by me from the previous installation of UECIDE version 0.8.7z36.
I deleted the whole C:UECIDE folder to make sure nothing was left. And then proceeded to install UECIDE version 0.8.8alpha22.
The reason this sub-folder was in C:UECIDE in the first place is because I copied the whole libraries folder from the other installation of MPIDE.
I wanted to see all the MPIDE libraries in UECIDE.

Anyhow, now that I know what caused the problem I can correct the situation.
My question now is: Should I delete the whole libraries folder on my D: drive ?
Prashant Tripathi :idea: Knowing is to the Self what knowledge is to the ego

User avatar
majenko
Site Admin
Posts: 2165
Joined: Wed Nov 09, 2011 7:51 pm
Location: UK
Contact:

Re: Compiler Output Stuck in a Loop

Post by majenko » Wed Feb 17, 2016 4:37 pm

Only if it causes you problems. No point in deleting stuff that might be useful in the future, that's what I always say ;)
Why not visit my shop? http://majenko.co.uk/catalog
Universal IDE: http://uecide.org
"I was trying to find out if it was possible to only eat one Jaffa Cake. I had to abandon the experiment because I ran out of Jaffa Cakes".

Post Reply