Page 3 of 4

Re: Official Release 20120903 Open Source Compiler

Posted: Fri Oct 12, 2012 3:08 am
by EmbeddedMan
I believe that this is because the standard libraries (for this version of the compiler) are all compiled with -fno-short-double, so you have to have your code match that or it won't work. That's just a guess though- Jason K would know for sure.


Re: Official Release 20120903 Open Source Compiler

Posted: Fri Oct 12, 2012 4:43 am
by artbecker
Is any official attention going to be made for this latest MPIDE version being unable to install under Ubuntu Linux 12.04? It really is disappointing to be ignored this way in the official thread.

The helpful suggestion of the preferences.txt fix only applies to Windows, as that file is used differently under Linux.

I bought the ChipKit board but it doesn't work under Linux, and I can't get any official acknowledgement that anything is being done to fix the problem.

Re: Official Release 20120903 Open Source Compiler

Posted: Fri Oct 12, 2012 1:46 pm
by EmbeddedMan
I apologize for not being able to answer your question or help you out - I only know Windows, so I can't really help with the Linux side of things. Almost all of the developers on the chipKIT/MPIDE team are just donating their spare time to the project, so you never really know when they'll be able to have time to look at a particular problem or not. Hopefully one of the other users or devs who knows Linux can help you solve your problem. Do previous versions of MPIDE work properly for you? Maybe you could use one of them for the time-being?


Re: Official Release 20120903 Open Source Compiler

Posted: Fri Oct 12, 2012 11:03 pm
by jumpin_jack
It's usually best to start a new thread for each issue or question as they tend to get lost in the noise when adding something new to an existing thread. But anyway, could it be related to the rxtx library as described on this wiki page? ... stallation

Re: Official Release 20120903 Open Source Compiler

Posted: Sun Oct 28, 2012 4:46 am
by bperrybap
I was able to get the release working on Ubuntu 10.10
(I refuse to run any Ubuntu release beyond that release) Not sure about these days,
but in the past I found that the LTS releases of ubuntu really
lag on being up to date with latest tools, apps, and drivers and for me were less
usable than the non LTS releases.

The one problem that I did have with the mpide release
is that File Roller (ubuntu GUI archiver) was unable to extract the files
from the .tgz or the .tar (if I uncompressed it with gunzip). File Roller got an error.
However, if I used the command line to uncompress the .tgz with gunzip
and then used tar to extract the files, it all worked as expected
and I was able to upload the blink example to an UNO32 board.

I went and tried an install in the latest mint release (mint 13) with mate.
I downloaded the release from the github server and then used the default mint13
gui archiver engrampa and that all worked flawlessly.
Then the first run fails and will fail until you set up the default sketchbook area.
Then when that is done you get the rxtx error.
This is cured by installing the librxtx-java package
Now compiles and links work.

The next error, and this is a serious tool error in the IDE that needs to be bugged.
The IDE wants to get the size of the binary to see if it is too large.
The bug is that the IDE is running avr-size even when a non avr mcu is being used.
While this is not an appropriate fix, you can temporarily work around this by
installing the binutils-avr package. This installs the AVR version of the binutils tools
which should not be needed but are currently needed do the bug in the IDE.
Luckily all the binutil programs are the same so the avr-size command works on the
pick32 images.

I'm guessing that nobody has ever tested mpide without any of the AVR tools installed.

Anyway, long story short, once the sketchbook directory is set, and
librxtx-java and bnutils-avr packages are installed, I was able to build and
upload the blink sketch to an uno32 board.

Since mint tends to draw quite a bit from Ubuntu, it is likely that this will
also work on the more recent Ubuntu releases.

--- bill

Re: Official Release 20120903 Open Source Compiler

Posted: Mon Dec 17, 2012 7:49 pm
by cobra18t
@artbecker and any other Ubuntu users:

I have got MPIDE working on Ubuntu 12.04 thanks to a post by Samuel Toepke. MPIDE was crashing due to a lack of dependencies. Try running the following command (one line) in a terminal (CTRL+ALT+T):

Code: Select all

sudo apt-get install openjdk-7-jdk librxtx-java ia32-libs libreadline6:i386 libelf1:i386 gcc-avr 
I am running the 64bit version of 12.04 and have not tested anything on the 32bit version. This got it working for me and I hope it works for you!

For reference and further detail, here is the original post by Samuel: ... index.html


Re: Official Release 20120903 Open Source Compiler

Posted: Sun Apr 07, 2013 2:56 pm
by dboechler
Cool project!

Anyway you can work in some enhancements to the MPIDE like this?,118440.0.html


Re: Official Release 20120903 Open Source Compiler

Posted: Wed Jan 15, 2014 2:05 pm
by YOBE.

can anybody please explain. I use release 201209 because it is mentioned under this topic. But when I look futher, I see the page on "current latest versions". There I find 201307 as release version and 201311 as test version.

It seems there are 2 "official releases" 201209 and 201307.

What do you suggest that I use.

At this moment I use 201209 because this seemed to be the one stated under "anouncements".


Re: Official Release 20120903 Open Source Compiler

Posted: Wed Jan 15, 2014 9:00 pm
by Ian_B
The release versions include the date they were released, so release 201209 was released in September of 2012, 201307 was released in July of 2013, etc. This announcement was made quite a while back, so it's safe to say 201209 is outdated.

Even though 20130715 is the latest release version, I would recommend going with 20131118-test. There is a rather significant bug for using Serial1 in 20130715, and each subsequent release (whether an official or test version) will have fixes or other changes, such as adding support for more boards.

The best place to get the current version of MPIDE is at:

Re: Official Release 20120903 Open Source Compiler

Posted: Fri Jan 17, 2014 7:02 am
by YOBE.

can somebody explain this issue.
I have been using release 20120903 for a while and recently changed to 20131118. Hoped this included some updates.

One problem I now encounter: my USB-dongle is on COM9(needed to communicate with my HC05).
BUT when I use serial monitor in version 20131118 it does not show COM9. Only COM3 (my UNO) and COM10 (no function)

When I use version 20120903 I can use COM3, COM9 and COM10 in my serial monitor.

So for some reason in version 20131118 I loose COM9 in serial monitor???