New to ChipKIT Pi

User avatar
Site Admin
Posts: 2188
Joined: Wed Nov 09, 2011 7:51 pm
Location: UK

Re: New to ChipKIT Pi

Post by majenko » Wed Mar 11, 2015 1:41 am

Maybe something in the C library, maybe something in the ELF decoder - who knows? Be interesting to compare the disassembly of both versions when we have a working slackware one.
Why not visit my shop?
Universal IDE:
"I was trying to find out if it was possible to only eat one Jaffa Cake. I had to abandon the experiment because I ran out of Jaffa Cakes".

Posts: 40
Joined: Wed Oct 01, 2014 6:05 pm

Re: New to ChipKIT Pi

Post by nroff-man » Wed Mar 11, 2015 11:34 am

sethkush wrote:pload worked. The 6502 simulator is really cool. I'm afraid I'm not very well versed in gdb, and I wasn't able to get anything useful from it. Adding "#include <stdint.h>" fixed the uint_16_t problem. Unfortunately, the build still fails because ld can't find "-lusb-1.0" which is odd, because when I run simply "ld -lusb-1.0" it does seem to find it and it's dependencies.
As an alternative to any IDE and high level libraries you can program
this chip in a more `bare metal' fashion.

This isn't straightforward and you would need to refer to lengthy Microchip
documentation for the part to learn about the peripherals.

This chipKIT Pi project here contains a minimal LED blinky demo.
You can use this blinky as a template for any project you like.

Ultimately though, you need a good idea of what you are setting
out to achieve before writing any code. You could do some minimal
research do find out if you think you are capable of doing it this way
or not in advance.

Good luck,

Post Reply