Search found 102 matches

by GastonLagaffe
Mon Dec 07, 2015 9:59 am
Forum: chipKIT Boards
Topic: Picadillo Demos
Replies: 6
Views: 506

Picadillo Demos

Salut, I tested all Picadillo Demos. Some comile, some fail compilation. Those that compile run nicely. This is the list of Demos that are OK: Aafont Benchmark Bezier Heart HSWave Mandelbrot PicadilloTest Primitives ScrolingWave Skribble WindowSemo These fail: 7Segment Compiling... • Compiling sketc...
by GastonLagaffe
Mon Dec 07, 2015 9:27 am
Forum: chipKIT Boards
Topic: Picadillo upload speed
Replies: 0
Views: 568

Picadillo upload speed

Salut, I have picadillo board now for some time and like it a lot. The board is fast, the display is good and I get more and more examples to run. There is one thing, that is not as good: the upload speed is very slow. It appears to me it runs at 57 kbaud as the upload of 19928 bytes take 31 seconds...
by GastonLagaffe
Wed Dec 02, 2015 4:30 pm
Forum: chipKIT Boards
Topic: Uno32 freezes *please help*
Replies: 29
Views: 1637

Re: Uno32 freezes *please help*

Salut, I have the picadillo as well and am very pleased by the board. I created two demos for the board: one that replays the UTFT demo, the second implements a little math game. I have not yet published them as they are not completely done and I am very busy from my day job (we have a fair in Londo...
by GastonLagaffe
Wed Aug 26, 2015 12:14 pm
Forum: chipKIT Boards
Topic: I2C and Interrupt routine
Replies: 4
Views: 577

Re: I2C and Interrupt routine

Salut, I found the DTWI library as part of the mpide distribution (latest 150 stable) in the wire subdirectory: mpide\hardware\pic32\libraries\Wire\ It is included in the chipKit-Git core as a library as well. The example of the Wire library called I2CMasterEEPROM uses DTWI. You have to selecet the ...
by GastonLagaffe
Thu Aug 13, 2015 10:09 am
Forum: chipKIT Boards
Topic: StarterKit Comparison Arduino ChipKit
Replies: 3
Views: 274

Re: StarterKit Comparison Arduino ChipKit

Salut,

yes, I would be interested in contributing to the wiki. It looks completely empty at the moment and creating an account returns: Account creation error
*** Forbidden. Please enable JavaScript. ***
I disables noscript without success.

Ciao, Mathias
by GastonLagaffe
Thu Aug 13, 2015 9:42 am
Forum: chipKIT Boards
Topic: StarterKit Comparison Arduino ChipKit
Replies: 3
Views: 274

StarterKit Comparison Arduino ChipKit

Salut, I have created and tested a documentation on how to use an Arduino Starterkit with a chipKit board. I show in 9 examples how to use the starterkit with an Arduino and with my HelvePic32 board. My intend is to show that there is a high similarity between the two platforms and that the code is ...
by GastonLagaffe
Thu Aug 13, 2015 9:34 am
Forum: IDE Integration
Topic: MPIDE menu problems
Replies: 3
Views: 354

Re: MPIDE menu problems

Salut,

it is the bluetooth - switch off the bluetooth adapter and MPIDE works as expected. Surprisingly, this is not an issue with the Arduino IDE or UECIDE

Ciao, Mathias
by GastonLagaffe
Thu Aug 13, 2015 8:35 am
Forum: IDE Integration
Topic: MPIDE menu problems
Replies: 3
Views: 354

MPIDE menu problems

Salut, as I tested my code with the MPIDE, I ran into a strange behavior: When starting MPIDE I get the expected empty screen. As I enter the menu bar to select an menu item, I experience that each time I move the mouse to the "Tools" item, I have to wait 15 seconds until the menu opens. I can then ...
by GastonLagaffe
Wed Aug 12, 2015 9:46 am
Forum: chipKIT Boards
Topic: Fubarino mini UART pin issue
Replies: 5
Views: 414

SOLVED: Fubarino mini UART pin issue

Salut, I was right with my guess that there is something working with the timing. The fubarino was flashed with the UECIDE hex file (found in the fubarino board definition folder). I now flashed the chip with the bootloader Fubarino-Mini_USB_48MHz.hex from UECIDE alpha18 and the serial output is per...
by GastonLagaffe
Wed Aug 12, 2015 9:13 am
Forum: chipKIT Boards
Topic: Fubarino mini UART pin issue
Replies: 5
Views: 414

Re: Fubarino mini UART pin issue

Salut,

I tried SoftwareSerial with the same result: The pins are assigend correctly but the printed output is garbled, It appears to me like there is a timing issue with the Fubarino definitions.

Ciao, Mathias